Supported Browsers

The Infosec Skills platform can be accessed with the two most recent versions of Chrome, Firefox, Edge, and Safari.

Other browsers may work, or work partially, but are not formally supported.